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ABSTRACT 

We have developed a program called NADS (Nuclear and Atomic Data System) which 
provides a web-based, user-friendly interface for viewing nuclear data.  NADS uses a client/server 
model.  The client is a Java applet that runs in a web browser.  The server is a Python code that 
delivers pointwise data to the applet per user request and then plots the data. The data is also 
stored in tables for viewing and modifying.  NADS can display 2-D, 3-D and 4-D (time sliced) 
data in a powerful, user-friendly environment.  Currently, evaluated nuclear data are available 
from ENDF/B-V, ENDF/B-VI, JENDL, JEF and Lawrence Livermore National Laboratory's 
ENDL databases.  LLNL’s ENDL database has data for neutron, gamma and charged particles as 
projectiles. In addition to displaying and saving data, NADS has the capability to perform 
computations with the data.  NADS is accessible over the Internet at http://nuclear.llnl.gov/.  
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1  INTRODUCTION 

1.1 Overview of Databases 
Fundamental to nuclear applications are the nuclear data which are fed into them.  The 

evaluated nuclear data are derived from the experimental data, which are stored in the EXFOR 
[1] database.  Each evaluator creates a nuclear data set based on certain principles, assumptions 
and analysis.  Currently, there are 6 major evaluations. They are: ENDF/B [2] from Brookhaven 
National Lab., ENDL [3] from Lawrence Livermore National Lab., JEFF [4] from Europe, 
JENDL [5] from Japan, BROND [6] from Russia and CENDL [7] from China.  All the databases 
except ENDL store their data using the ENDF/B format.  This format is a combination of 
pointwise and parametric data. ENDL only uses a pointwise data format.    

Since nuclear data are important, visualization tools have been created to view the data.  
Brookhaven National Laboratory [8] and Los Alamos National Laboratory [9] offer web forms to 
visualize some of the data.  JANIS [10] represents a user-friendly graphical approach to view the 
experimental and evaluated nuclear data.  Lawrence Livermore National Laboratory has 
developed its own nuclear data viewer called NADS: Nuclear and Atomic Data System.   

1.2 Features of NADS 
NADS is available through the Internet by pointing a Java 1.4+ enabled browser to 

http://nuclear.llnl.gov/.  It presents a user-friendly graphical interface for viewing nuclear data 
such as neutral and charged particle cross sections, outgoing spectrum distributions and outgoing 
energy.  The data are shown in tables as well as in interactive 2-D, 3-D and 4-D plots.  The data 
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and plots may be copied and pasted into other documents.  NADS also presents a powerful 
computational ability for manipulating data.  An online help menu is available to explain each 
feature. 

1.3 Benefits to Users 
One of the main uses for NADS is to look at cross section data to see if they make sense in 

light of an experiment or calculation.  Comparing evaluations is another use for NADS.  Some 
users may wish to check evaluated data versus experimental data with uncertainties.  Plotting 
cross sections for a presentation or exporting the data to a spreadsheet is yet another benefit.  
Finally, some may use NADS for computations such as determining macroscopic cross sections 
or looking at attenuation in a slab as a function of energy. 

 

2 POINTWISE DATA 

As mentioned in the Introduction, LLNL uses the ENDL format.  ENDL is a pointwise 
format. LLNL database has data for neutron, gamma and charged particles as projectiles.  In 
addition, spectrum and outgoing energy data are available.   

Figure 1. Screen capture of NADS’s data tree viewer.  In this example the evaluated data branch is opened. 
Under this, the user has opened LLNL’s endl94 database which shows a list of available projectiles. The user 
has opened deuteron as a projectile which shows a list of available targets (only hydrogen is visible). The 
hydrogen target has been opened and a list of reactions shown. The H-1(d, n p)H-1 reactions has been opened 
and its cross section is highlighted. 
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Since most of the world uses ENDF/B format, a translation program was developed called 
Fête [11] that converts ENDF/B-VI formatted data into ENDL formatted data.  Currently, 
translated versions of ENDF/B-V, ENDF/B-VI, JEFF and JENDL are available via NADS.  In 
addition, LLNL’s processed deterministic data (ndf) and cross-section data from EXFOR are also 
available. 

A user chooses data in NADS by opening the data directory viewer as shown in Figure 1.  In 
this figure, the tree has been expanded to show the evaluated databases.  Under “endl94” the 
projectile deuteron was opened.  The hydrogen-1 target has been chosen followed by the reaction 
in which the incident deuteron breaks up into a neutron and proton.  The next level shows the 
data itself in a color coded format.  The dimensionality of the data is represented with colors 
where red, pink and blue mean 2-D, 3-D and 4-D, respectively.  The green “Target Option” leaf 
may be double clicked to enter target options such as the temperature of the target for heating of 
cross section data.  

 Double clicking on a data leaf downloads the data from the server, plots the data and stores 
it in a table.  The data may also be sent to the “Computation” window described below.  
Selecting multiple sets of data allows for all the data to be plotted all at once.  In the case of a 
computation, the data are sent to the computation window as a merged data.  

3 CLIENT / SERVER MODEL 

NADS works under a client/server model as demonstrated in Figure 2.  The client is a Java 
applet while the server is a Python program that connects to various routines to serve up the data.  
Java was picked as the client because it runs on many platforms, is found in most common 
Internet browsers, has high security, and has strong features for networking and graphing.  
NADS is designed to be an applet as opposed to an application so it can be upgraded with no 
redistribution of the executable.  

 
The client and server communicate across the Internet using an XML-formatted protocol.  

This simple breakup in handling communication decouples the client and server development 
except for message passing.  The NADS server communicates with access routines to read in the 
data and perform any needed manipulations such as heating or weighting.  

NADS
Server

Client 1

Client 2

Client 3

Nuclear 
Data 

Access
Routines

Figure 2. Clients send requests to the server which uses access routines to gather the data and return 
them to the clients. 
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4 PLOTTING 

4.1 2-D Plotting 
An example of a 2-D plot is shown in Figure 3.  This figure shows a plot of the total cross 

section of oxygen-16. The red data is experimental data from EXFOR with the uncertainties 
shown.  The cyan line is the ENDL94 data.  The plot is zoomed in to show how well the 
evaluated data matches this experimental data. 

 The plot is made up of components such as the graph, legend, title and axis labels.  A 
component can be moved by clicking on it and dragging it.  Clicking and dragging in one of the 
border grow boxes allows for the component to stretch or shrink. 

Right-clicking on a component allows for one to position it in front or behind other 
components.  The user may select the properties option as shown in Figure 4.  Many options may 
be selected such as autoscaling, linear/log axis, label names, fonts and marker/line styles.  

Dragging in the graph creates a rectangle that allows for zooming in or out.  One can zoom 
into the whole rectangle or just the horizontal or vertical axes can zoom.  For zooming out, the 
larger the rectangle, the further out the plot will expand. 

Figure 3. Comparison of EXFOR data to Endl94 for the total cross section for a neutron hitting oxygen-16 
from 3 MeV to 7.3 MeV. 
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4.2 3-D and 4-D Plotting 
NADS can display 3-D and 4-D data in user-controlled plots as well.  A 4-D plot is a series 

of 3-D plots where the 4th dimension is treated like “time.”  An example of a 4-D plot is given in 
Figure 5.  A user may adjust the different axes with the controls on the right.  Rotation may be 
accomplished with the controls or by clicking and dragging in the plot window.  The “time” axis 
may be selected or animated with the controls in the bottom right.  There are also options to fully 
scale the current “time” to fill the current plot window.  The 3-D plot is just like this plot except 
the “time” axis controls are not present. 

Chart options are available under the “Chart” menu.  The option dialog allows for linear/log 
to be set for the three major axes.  It allows for different line coloring as well as selecting the 
symbol.  Other options such as allowing for cross hatching of the lines as well as changing plot 
size may be set as well. 

Figure 4. Properties for the 2-D plot.  Other options may be chosen 
by selecting the tabs at the top. 
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5 TABLES 

All data plotted are stored in a table where each row represents a point.  Data may be copied 
and pasted to and from other applications such as text processors or spreadsheets.  Using the 
controls on the right side of a table as shown in Figure 6, one can add or delete highlighted rows.  
Data may be entered by hand and plotted, or sent to the computation window for further 
manipulation. 

Figure 5. 4-D plot example for the outgoing angle and energy distribution of a neutron for the  
Be-9 + n → 2n + 2He reaction. 
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The “Table” menu offers options to rename column headers, change table title or change the 
number of columns.  The names “Positive dx”, “Negative dx”, “Positive dy” and “Negative dy” 
are reserved names showing relative uncertainty on the x and y axes.  

Tables may also be saved and loaded from the “File” menu.  All cut/paste and file operations 
involve extending security policies to the NADS applet so it has permission to access these 
functions.  Check out the “Frequently Asked Questions” on the main page for directions on how 
to set up policy permissions. 

 

6 COMPUTATIONS 

One of the most powerful tools available in NADS is the ability to do computations on the 
data.  Computations are performed in the computation window as shown in Figure 7. To send 
data to the computation window, selected the desired data from the data directory window as 
shown in Figure 1. Then, click on the “Compute with Selected” button to send the data to the 
computation window.  In the computation window, the data are accessed through variables 
(under the symbol heading).  In the example in Figure 7, the symbols “a” and “c” are the total 
cross sections for a neutron hitting carbon and hydrogen, respectively.  “b” and “d” are the 
corresponding capture cross sections.  The equation “a + 2 * c” is set to the variable “e” by 

Figure 6. Table example of the total cross section from neutron hitting hydrogen-1 from the  
EXFOR database.  Uncertainties in the y axis are shown in the two right columns.. 
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typing the equation and pressing the “Store” button.  The final equation shown, “(1 – exp(-2 * e)) 
* f / e”, is then plotted by clicking on the “Process” button.  Many functions beside the exponent 
function are available and are described under the “Help” menu.  The computation session may 
be saved to a text file under the “File” menu.   

 
If several sets of data are selected in the database directory window and sent to the 

computation window, they are stored as a merged entity.  For 2-D evaluated data, this is 
equivalent to the data being added together.  However, the EXFOR data are not lines, but points.  
So a merge of this type of data just combines all the points.  Computations for 3-D and 4-D are 
not supported at this time. 

User defined data may be entered into a new blank table and sent to the computation 
window.  This allows for many advanced computations to take place such as flux weighting or 
modifying cross sections. 

7 FUTURE WORK 

NADS development is an ongoing project with many features planned for the future.  Some 
of the upcoming enhancements are 

1. A relational database search capability. 

2. Plotting ACE formatted files. 
3. Plotting of EXFOR distribution data 
4. Faster 2-D plotting of very large data sets. 

5. To allow for text and arrows to be placed on 2-D plots. 
6. To package the 2-D plotter as freeware for others to use. 

Figure 7. Computation window example showing the capture fraction as a function of energy for CH2. 
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Feature requests to NADS may be submitted by email to the authors or by using the 
“Feedback” dialog under the “File” menu. 
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